установка определенной версии пакета в debian, ubuntu

До установки требуемой версии пакета можно посмотреть

apt-cache showpkg <package name>

н.р..
apt-cache showpkg subversion-tools

> Package: subversion-tools > Versions: > 1.3.2-5~bpo1(/var/lib/dpkg/status) > 1.1.4-2 (/var/lib/apt/lists/ftp.uk.debian.org_debian_dists_stable_main_binary-i386_Packages)

Для установки требуемой версии выполните:
apt-get install <package name>=<version>

или aptitude install <package name>=<version>

н.р.
apt-get install subversion-tools=1.3.2-5~bpo1

Узнать имеющиеся в кеше предыдущие версии можно командой (для Ubuntu)

ls -l  /var/cache/apt/archives/ | grep <package name>

Посмотреть доступные версии пакета в репозитории можно командой:

aptitude versions <package name>

Добавить комментарий

Войти с помощью: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *